Fault M2508 2958 (Priority 2)

Major incident KVK diensten Diensten voor notarissen NAU - Notaris Applicatie UBO
20-08-2025 10:41 CEST · 2 hours, 9 minutes

Updates

Resolved

The problem with UBO-NAU has been resolved.
You can once again use this service as normal.

20-08-2025 · 12:10 CEST
Update

Unfortunately, we are still experiencing an outage with UBO-NAU.

As a result, you cannot use the UBO submission service for existing Chamber of Commerce (KVK) registrations. However, the UBO submission service for new KVK registrations remains available.

The cause has been identified.
A solution is currently being worked on.
There is still no estimated time of resolution.

You will receive the next update around 12:45.

20-08-2025 · 11:36 CEST
Issue

Unfortunately, we are currently experiencing an outage with UBO-NAU.

As a result, you cannot use the UBO submission service for existing Chamber of Commerce (KVK) registrations. However, the UBO submission service for new KVK registrations is still available.

A solution is currently being worked on.
There is no estimated time of resolution.

You will receive the next update around 11:45.

20-08-2025 · 10:41 CEST

← Back