Disruption on KVK.nl (Priority 1)
Major incident
KVK.nl
05-12-2025 09:53 CET
· 23 minutes
Updates
Resolved
05-12-2025 · 10:13 CET
The disruption affecting KVK.nl has been resolved.
You can use the service again as expected.
Issue
05-12-2025 · 09:53 CET
Unfortunately, we are currently experiencing an issue accessing the KVK.nl website.
As a result, KVK.nl is temporarily unavailable and its pages and functionalities cannot be reached.
Work is underway to resolve the issue.
No estimated time of resolution is available yet.
You will receive the next update around 10:30.
← Back