Fault M2605 3342 (Priority 1)

Major incident KVK.nl
28-05-2026 10:54 CEST · 12 hours, 25 minutes

Updates

Resolved

The issue with our website kvk.nl has been resolved.

28-05-2026 · 23:20 CEST
Investigating

Unfortunately, we are still currently experiencing an outage with our kvk.nl website.

As a result, our website is not functioning as you are accustomed to. You may need to refresh the page several times. We are still working on a solution.

28-05-2026 · 18:05 CEST
Investigating

Unfortunately, we are still currently experiencing an outage with our kvk.nl website.
As a result, our website is not functioning as you are accustomed to. You may need to refresh the page several times. We are still working on a solution.

28-05-2026 · 16:31 CEST
Issue

Our website kvk.nl is currently not functioning as you are accustomed to. You may need to refresh the page several times. We are working on a solution.

28-05-2026 · 10:54 CEST

← Back