Fault M2608 3314 (Priority 1)

Major incident KVK.nl
31-08-2026 12:15 CEST · 50 minutes

Updates

Resolved

The problem with KVK.nl has been resolved.
You can once again use this service as normal.

31-08-2026 · 13:15 CEST
Issue

Unfortunately, we are currently experiencing problems with our website KVK.nl

Because of this, you can make only limited use of KVK.nl.

A solution is currently being worked on.
A resolution time is not yet available.

You will receive the next update around 13:15

31-08-2026 · 12:40 CEST

← Back